I want to upgrade my account, but it says I already have a subscription
Problem:
You are a Bronze user. You have clicked the Upgrade button and selected a plan, but you receive an error telling you that you already have a subscription.
Cause:
You have previously had a paid subscription on Mega Seating Plan. This is stopping a new one from being created.
Solution:
Instead of clicking the 'Upgrade' button, click on your name on the top menu bar. Then choose 'Manage subscription'. This should allow you to reactivate your previous subscription.
Updated on: 08/09/2024